Search:
Attention Honda Civic Visitor:  Remove this block by logging in above or registering.

Welcome to ClubCivic

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the member’s garage to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


Go Back   ClubCivic.com - Honda Civic Forum > Honda Civic Technical > Tech Archive (No Posting)

Notices

Tech Archive (No Posting) This will also temporarily hold all of the old gen specific threads until they are all moved to the correct categories.

Please SEARCH Before Posting a New Thread. ->
Ready to Post a New Thread/Question? ->  



Some Indicator lights do not work!

Tech Archive (No Posting)


Technical forums are exclusively for technical discussions.
Thread Makers: Thread titles must summarize the technical question or problem, and the first post must include the year, trim, and any mods for your Civic.
Responding Members:
Limit your posts to helpful responses, and do not tell members to "Go Search", unless you also provide some specific guidance on the technical question or problem.
All Members: Rude or flaming posts will not be tolerated, though civil debate and disagreement are acceptable.


 
Thread Tools
Old 03-02-2008, 04:28 PM   #1
dementor
Registered User
 
Join Date: Jun 2007
Location: Montreal
Posts: 19
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default Some Indicator lights do not work!

Hi guys,
I just noticed several of my indicator lights do not work on my Canadian 00 civic SE - and yes, they used to! I don't know when they stopped working. Here are the ones that DO NOT work:

-low oil pressure indicator
-parking brake indicator
-ABS indicator
-Malfunction Indicator lamp
-Low fuel indicator
-washer level indicator

The rest work fine, and illuminate when I have my key in the on position.

What do you guys think the problem is? Fuse? Light bulbs? Something else?
dementor is offline  
Old 03-02-2008, 04:55 PM   #2
knightxrider1
Registered User
 
knightxrider1's Avatar
 
Join Date: Sep 2007
Location: Sunshine State
Age: 25
Posts: 3,151
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

take the cluster out. w that many probs. maybe the harness in the back is loose.
knightxrider1 is offline  
Old 03-02-2008, 05:03 PM   #3
dementor
Registered User
 
Join Date: Jun 2007
Location: Montreal
Posts: 19
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

Ok I took the cluster out, I have it here in my hands hehehe
I made a mistake... not all those lights are out. Just these 3:

-Low fuel indicator
-washer level indicator
-Trunk indicator

It doesn't appear to be the light bulbs.
dementor is offline  
Old 03-02-2008, 05:11 PM   #4
simmons
Registered User
 
simmons's Avatar
 
Join Date: Jan 2008
Location: England, UK
Age: 23
Posts: 30
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

try looking for broken fuses, this has happened to me before and a couple of fuses needed replacing
simmons is offline  
Old 03-02-2008, 05:29 PM   #5
dementor
Registered User
 
Join Date: Jun 2007
Location: Montreal
Posts: 19
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

Any specific fuses? itd be annoying (and COLD!) to go through every fuse in the car looking for a broken one.
dementor is offline  
Old 03-02-2008, 05:34 PM   #6
simmons
Registered User
 
simmons's Avatar
 
Join Date: Jan 2008
Location: England, UK
Age: 23
Posts: 30
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

pop the bonnet and the fuse box lid should have a diagram showing which fuses affect certain areas.

look for the one you're having problems with and hopefully that means you won't have to go through all of them! cold? you woman!
simmons is offline  
Old 03-03-2008, 12:50 PM   #7
dementor
Registered User
 
Join Date: Jun 2007
Location: Montreal
Posts: 19
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

Should it be the fuse box under the dash, or under the hood?
dementor is offline  
Old 03-04-2008, 12:20 PM   #8
dementor
Registered User
 
Join Date: Jun 2007
Location: Montreal
Posts: 19
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

Ok, fuses look good, light bulbs are fine... What else can I potentially check?
dementor is offline  
Old 05-14-2008, 05:02 AM   #9
Lisa-Adam
Registered User
 
Join Date: May 2008
Location: USA
Posts: 1
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

In this forum there is no any person who suggest you better. So Suggest to mechanic.
__________________
Get information about Gary Winnick from The New York Times.
Lisa-Adam is offline  
Old 05-18-2008, 12:18 PM   #10
Shamus
Registered User
 
Join Date: May 2008
Location: NJ
Posts: 91
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

I have the same problem with my 00 EX. Let me know if you figure anything out.
I swapped bulps, checked fuses, and wiring. So far, nothing!
Shamus is offline  
 


Bookmarks



Similar Threads
Thread Thread Starter Forum Replies Last Post
parking lights work but the brake lights dont, confusedddd! HELP Jabes Interior / Audio / Electronics 0 08-18-2011 12:13 PM
What lights SHOULD work? civic21911 Interior / Audio / Electronics 2 11-18-2010 12:01 AM
reverse lights dont work and right turn signal doesn't work 100% jazzyJAE Interior / Audio / Electronics 5 09-14-2010 09:13 PM
low beams, tail lights, park lights, and brake lights dont work? scotty0607 Interior / Audio / Electronics 3 09-12-2010 04:15 AM
blinkers wont work but hazard lights work. hondamnit99 Exterior / Detailing / Bodywork 3 03-14-2009 01:22 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 08:57 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors

Store News:

Latest Topics:


Store Specials:

ALL
Unanswered Topics:





Copyright 2011 ClubCivic.com - ClubCivic.com is in no way affiliated with Honda Motor Company