Search:
Attention Honda Civic Visitor:  Remove this block by logging in above or registering.

Welcome to ClubCivic

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the member’s garage to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


Go Back   ClubCivic.com - Honda Civic Forum > Honda Civic Technical > Tech Archive (No Posting)

Notices

Tech Archive (No Posting) This will also temporarily hold all of the old gen specific threads until they are all moved to the correct categories.

Please SEARCH Before Posting a New Thread. ->
Ready to Post a New Thread/Question? ->  



Engine hesitation: Bad O2 sensor?

Tech Archive (No Posting)


Technical forums are exclusively for technical discussions.
Thread Makers: Thread titles must summarize the technical question or problem, and the first post must include the year, trim, and any mods for your Civic.
Responding Members:
Limit your posts to helpful responses, and do not tell members to "Go Search", unless you also provide some specific guidance on the technical question or problem.
All Members: Rude or flaming posts will not be tolerated, though civil debate and disagreement are acceptable.

User Tag List


 
Thread Tools
Old 06-01-2010, 10:49 AM   #1
CIVIC_VTEC
LOW AND SLOW!
 
CIVIC_VTEC's Avatar
 
Join Date: Feb 2010
Location: Indiana
Posts: 349
 

Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default Engine hesitation: Bad O2 sensor?

ok when im driving around town or anywere for that fact, i feel my car hessatating sometimes, like jerking, not as fast etc. but im guessing its the o2 sensor, that messurse the amout of air and so on. and i do notice the cars ok in gas and should be faster, but de to the o2 sensor not that much. am i right?
__________________
LOW AND SLOW

CIVIC_VTEC is offline  
Old 06-01-2010, 10:50 AM   #2
CIVIC_VTEC
LOW AND SLOW!
 
CIVIC_VTEC's Avatar
 
Join Date: Feb 2010
Location: Indiana
Posts: 349
 

Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

and sorry for the spelling its not the best.
__________________
LOW AND SLOW

CIVIC_VTEC is offline  
Old 06-01-2010, 12:50 PM   #3
DROK604
Registered User
 
DROK604's Avatar
 
Join Date: May 2010
Location: canada
Posts: 36
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

I would also check that the iacv is clean. I'm planning on cleaning mine this week
DROK604 is offline  
Old 06-01-2010, 02:25 PM   #4
The_Rookie
Registered User
 
The_Rookie's Avatar
 
Join Date: Sep 2009
Location: ILLINOIS
Posts: 210
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

CAT converter
The_Rookie is offline  
Old 06-01-2010, 02:39 PM   #5
nicoyita1
I eat rice. And beans.
 
nicoyita1's Avatar
 
Join Date: Apr 2008
Location: East Coast
Posts: 1,134
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

Is your CEL on? If so, pull codes.
__________________
__________________________________________________ _________________________________________________
91 Toyota MR2 N/A (sw20) -DD
97 Ranger 2.3L -Sold
94 Toyota 4x4 22re pickup -Sold
91 Toyota 4x4 22re pickup -Sold
03 ES2 -RIP
98 VSM EJ8-Sold
92 EG8-Sold
95 Sentra-4 door DD
02 DC5-Play toy
nicoyita1 is offline  
Old 06-01-2010, 02:54 PM   #6
RonJ
Banned
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,102
 
Thanks: 0
Thanked 118 Times in 113 Posts
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)

Default

Quote:
Originally Posted by nicoyita1 View Post
Is your CEL on? If so, pull codes.


Also check the spark plugs, wires, cap and rotor, as well as the ignition timing.

If you believe the primary O2 sensor is at fault, then unplug it to see whether the problem goes away.
RonJ is offline  
Old 06-02-2010, 10:38 AM   #7
CIVIC_VTEC
LOW AND SLOW!
 
CIVIC_VTEC's Avatar
 
Join Date: Feb 2010
Location: Indiana
Posts: 349
 

Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default car hesitating when taking off

ok,recently i have noticed my car when i take off it shakes a bit, but you can notice it, and allso i have noticed the hp loss and mgp loss. but i am pretty sure that it could be the o2 sensor. Front (upstream) oxygen sensor. im pretty sure thats what it is.

which would be the second o2 sensor you see in the picture



__________________
LOW AND SLOW

CIVIC_VTEC is offline  
Old 06-02-2010, 10:45 AM   #8
RonJ
Banned
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,102
 
Thanks: 0
Thanked 118 Times in 113 Posts
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)

Default

Quote:
Originally Posted by CIVIC_VTEC View Post
ok,recently i have noticed my car when i take off it shakes a bit, but you can notice it, and allso i have noticed the hp loss and mgp loss. but i am pretty sure that it could be the o2 sensor. Front (upstream) oxygen sensor. im pretty sure thats what it is.

which would be the second o2 sensor you see in the picture
Only one thread per topic please. Two threads merged.

Rear = secondary O2 sensor.
RonJ is offline  
Old 06-02-2010, 08:41 PM   #9
CIVIC_VTEC
LOW AND SLOW!
 
CIVIC_VTEC's Avatar
 
Join Date: Feb 2010
Location: Indiana
Posts: 349
 

Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

Quote:
Originally Posted by RonJ View Post
Only one thread per topic please. Two threads merged.

Rear = secondary O2 sensor.
yess im sorry, i didn see my original one on here
__________________
LOW AND SLOW

CIVIC_VTEC is offline  
Old 06-02-2010, 11:09 PM   #10
RonJ
Banned
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,102
 
Thanks: 0
Thanked 118 Times in 113 Posts
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)

Default

Quote:
Originally Posted by CIVIC_VTEC View Post
yess im sorry, i didn see my original one on here
No problem.
RonJ is offline  
 




Bookmarks



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange engine hesitation JohnS. 6th Generation Honda Civic (1996-2000) 36 12-03-2011 10:44 PM
Hesitation on accelerating when engine is warm ryn004 Engine Tech / Drivetrain 4 11-24-2011 11:28 AM
engine hesitation. Skat3r_666 Engine Tech / Drivetrain 1 02-18-2011 03:29 PM
Help with 92 VX-Vtech engine hesitation during constant speed. rlopez1992 Engine Tech / Drivetrain 5 04-21-2006 07:42 PM
engine bog/hesitation on b16 00 Si N/A_SI Engine Tech / Drivetrain 7 05-18-2004 08:06 PM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:13 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors
User Alert System provided by Advanced User Tagging v3.1.3 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 2007 ClubCivic.com
Best Prices on Aftermarket Car Performance Parts
Freelance Web Design

Store News:

Latest Topics:


Store Specials:

ALL
Unanswered Topics:





Copyright 2011 ClubCivic.com - ClubCivic.com is in no way affiliated with Honda Motor Company