Search:
Attention Honda Civic Visitor:  Remove this block by logging in above or registering.

Welcome to ClubCivic

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the member’s garage to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


Go Back   ClubCivic.com - Honda Civic Forum > Honda Civic Technical > Interior / Audio / Electronics

Notices

Interior / Audio / Electronics Anything Interior related Including interior electronics

Please SEARCH Before Posting a New Thread. ->
Ready to Post a New Thread/Question? ->  



speedometer/odometer not working

Interior / Audio / Electronics


Technical forums are exclusively for technical discussions.
Thread Makers: Thread titles must summarize the technical question or problem, and the first post must include the year, trim, and any mods for your Civic.
Responding Members:
Limit your posts to helpful responses, and do not tell members to "Go Search", unless you also provide some specific guidance on the technical question or problem.
All Members: Rude or flaming posts will not be tolerated, though civil debate and disagreement are acceptable.


Reply
 
Thread Tools
Old 03-20-2011, 01:40 PM   #1
marewrath
Registered User
 
Join Date: Mar 2011
Location: Rochester, NY
Posts: 7
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default speedometer/odometer not working

I have a 97 civic dx; this was a salvage car fixed up at a junkyard and they did some pretty extensive work on this guy and it seemed like reallly good condition. the only issue i noticed initially was it took a bunch of turns to get started, but i didnt really have any problems until id had it for a month or so, and, long story short, had to drive through water around 5 inches high for about 5 or 6 yards. the issues came a week or so after and im not positive if they are related;

the battery began to die; something was drawing power while the car was off. at the mechanic they replaced the alternator, but i was still having the problem. I cant remember if this happened before or after i brought it to him at this point, but the speedometer was at 0, not working at all, and no mileage was being recorded. when they finally did something so that it stopped drawing power, im not sure exactly what it was --he had me get a piece for the fuse box in the hood, and that hadnt fixed it, and he said in the end all he did was take out a fuse.

i no longer had to unplug my batter when i turned the car off, but the speedometer and odometer is not working. he told me to get a speedometer sensor, but needless to say, i have stopped listening to/going to this mechanic.
I don't know a whole lot about cars, obviously, but i know that an electronic diagnosis could run me a lot more, especially because i don't--i was wondering if anyone had clues as to what it could be?
marewrath is offline   Reply With Quote
Old 03-20-2011, 01:51 PM   #2
RonJ
Registered User
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,095
 
Thanks: 0
Thanked 113 Times in 108 Posts

Default

Check whether 7.5A dash fuse 15 is blown.

Any CEL codes being thrown?
RonJ is offline   Reply With Quote
Old 03-20-2011, 01:54 PM   #3
2NRSTV
Team Exile/ADO Garage
 
2NRSTV's Avatar
 
Join Date: Mar 2010
Location: Monterey, CA
Age: 27
Posts: 741
 


Thanks: 0
Thanked 1 Time in 1 Post

Default

Sounds like the VSS (Vehicle Speed Sensor) is bad. Go pick one up and slap it on. Also, since he took out a fuse under the hood, you might want to see which one it was and if you need it. But the VSS is pretty easy to replace. here's where to find it:

It will be bolted to the backside of the transmission in this area.

This is what you are looking for. It shouldn't take more than 5-10 minutes to replace.
__________________
Feel free to visit TeamExile.Org to ask questions.
Or Email me directly to Tuner Steve
2NRSTV is offline   Reply With Quote
Old 03-20-2011, 01:58 PM   #4
RonJ
Registered User
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,095
 
Thanks: 0
Thanked 113 Times in 108 Posts

Default

^I think you generally give good advice, but in this case I don't understand your logic of replacing the VSS without doing some basic troubleshooting first. That's just replacing parts at random, which gets expensive and time consuming.
RonJ is offline   Reply With Quote
Old 03-21-2011, 08:32 AM   #5
marewrath
Registered User
 
Join Date: Mar 2011
Location: Rochester, NY
Posts: 7
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

yes - as i mentioned above, i knew it could be the speedometer sensor but don't want to keep throwing down money when troubleshooting was apparently justme doing that--im glad you told me how to replace it on my own but that mechanic said he would do it for free if i got the piece, still, i like to know.
i did do a little research before posting here, so ive check fuse 15 and it wasn't blown--just didn't want to bias replies. and when i asked what fuse the mechanic said it was the 'master fuse." which i dunno anything about, but sounds important, right? ha
marewrath is offline   Reply With Quote
Old 03-21-2011, 08:34 AM   #6
marewrath
Registered User
 
Join Date: Mar 2011
Location: Rochester, NY
Posts: 7
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

oh and CEL codes! - ive had 2 since the water, the second went on two days ago: it was PO420 car efficiency below threshold. the first one (which occurred nearly immediately after the water) was a piston wet deal - and this problem didnt occur until weeks later.
marewrath is offline   Reply With Quote
Old 03-21-2011, 09:32 AM   #7
RonJ
Registered User
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,095
 
Thanks: 0
Thanked 113 Times in 108 Posts

Default

Quote:
Originally Posted by marewrath View Post
oh and CEL codes! - ive had 2 since the water, the second went on two days ago: it was PO420 car efficiency below threshold. the first one (which occurred nearly immediately after the water) was a piston wet deal - and this problem didnt occur until weeks later.
P0420 almost surely means the cat is dead. What was the other code (there's no piston wet sensor unless you mean one of the misfire codes)? I notice there no VSS code. You need to check installed fuse 15 for voltage on both top test tabs to be sure it's fine.
RonJ is offline   Reply With Quote
Old 04-20-2011, 09:46 PM   #8
maclaban
Registered User
 
Join Date: Apr 2011
Location: OHIO
Posts: 3
 
Thanks: 0
Thanked 0 Times in 0 Posts

Default

Can anyone help? I got a 2008 civic and my speedometer ,tachometer and my temp gauge dont work! Any help please?
maclaban is offline   Reply With Quote
Reply




Bookmarks



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer and odometer not working 92 cx Dnguyen92 Interior / Audio / Electronics 9 09-30-2011 03:36 AM
Speedometer and odometer not working!! jrodriguez07 Engine Tech / Drivetrain 6 04-14-2011 06:41 PM
Speedometer and Odometer not working 31dev31 Tech Archive (No Posting) 6 04-12-2010 05:18 PM
99 honda civic si Speedometer and Odometer not working CivicSF Tech Archive (No Posting) 21 08-30-2009 11:19 PM
Speedometer and odometer problem kevin12 Tech Archive (No Posting) 6 05-13-2009 10:27 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:39 AM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors

Store News:

Latest Topics:


Store Specials:

ALL
Unanswered Topics:





Copyright 2011 ClubCivic.com - ClubCivic.com is in no way affiliated with Honda Motor Company