Search:
Attention Honda Civic Visitor:  Remove this block by logging in above or registering.

Welcome to ClubCivic

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the member’s garage to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


Go Back   ClubCivic.com - Honda Civic Forum > Honda Civic Technical > Engine Tech / Drivetrain

Notices

Please SEARCH Before Posting a New Thread. ->
Ready to Post a New Thread/Question? ->  



Speedometer and odometer not working!!

Engine Tech / Drivetrain


Technical forums are exclusively for technical discussions.
Thread Makers: Thread titles must summarize the technical question or problem, and the first post must include the year, trim, and any mods for your Civic.
Responding Members:
Limit your posts to helpful responses, and do not tell members to "Go Search", unless you also provide some specific guidance on the technical question or problem.
All Members: Rude or flaming posts will not be tolerated, though civil debate and disagreement are acceptable.

User Tag List


Reply
 
Thread Tools
Old 04-09-2011, 06:11 PM   #1
jrodriguez07
Registered User
 
Join Date: Apr 2011
Location: CA
Posts: 3
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default Speedometer and odometer not working!!

Can anyone help me with this dilemma, My speedometer and odometer is not working and well im assuming it probably my VSS that isnt working. Im wondering if you need professional work to install the new VSS or is there a specific way to install it because i dont want to pay for expensive labor!

thanks
jrodriguez07 is offline   Reply With Quote
Old 04-09-2011, 06:33 PM   #2
RonJ
Banned
 
Join Date: Oct 2007
Location: Houston, TX
Posts: 13,102
 
Thanks: 0
Thanked 118 Times in 113 Posts
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)

Default

Start by inputting you vehicle information here:

http://www.clubcivic.com/board/garag...do=add_vehicle
RonJ is offline   Reply With Quote
Old 04-10-2011, 01:47 PM   #3
askaterincville
Registered User
 
askaterincville's Avatar
 
Join Date: Aug 2009
Location: Somerset, Ketucky
Posts: 88
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

your vss is on the back of your transmission it has one 10mm bolt that holds it in and it will come right out, alot of them get corroded it seems. You can get to it from the engine bay on the passenger side its in the very back of the transmission and closest to the firewall. I would check the plug first on it and see what its like, and you can spin it with you fingers once its out of the trans. Check it by spinning the gear and having someone watch your speedo while you do it. it shouldnt take but about 30mins tops to pull it out and check it. Hope that helps.
askaterincville is offline   Reply With Quote
Old 04-10-2011, 11:39 PM   #4
jrodriguez07
Registered User
 
Join Date: Apr 2011
Location: CA
Posts: 3
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

@ askater, thank yeah i did that once my speedometer stopped working. but on my vss there wasnt no bolt either they must of never screw it back on or the previous owner never put the screw back in. I just twisted it around it pulled it out. i unplugged the connection and plugged it back in but nothing.. when your talking about spinning the gear on the vss do i do it while its connect to the harness and while its on?
jrodriguez07 is offline   Reply With Quote
Old 04-11-2011, 12:38 PM   #5
askaterincville
Registered User
 
askaterincville's Avatar
 
Join Date: Aug 2009
Location: Somerset, Ketucky
Posts: 88
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

yeah to check it just pull it out and leave the sensor plugged in and start the car and spin the gear with you fingers while someone checks to see if the speedo is moving. And check to make sure there isnt alot of corrosion in the plug.
askaterincville is offline   Reply With Quote
Old 04-14-2011, 05:34 AM   #6
96skuter
Registered User
 
96skuter's Avatar
 
Join Date: Apr 2011
Location: in the hood
Posts: 70
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

same problem here but i also think it might be the cluster.
96skuter is offline   Reply With Quote
Old 04-14-2011, 07:41 PM   #7
Pocket_eh
Ordering Civic HB Parts
 
Join Date: Jun 2009
Location: Boonies, Alabama
Posts: 96
 
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)

Default

check your plug on your dizzy, and the the plug on the driver side firewall. and its easy to put a VSS in. probably the easiest thing in the whole car to replace.
Pocket_eh is offline   Reply With Quote
Reply




Bookmarks



Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer and odometer not working 92 cx Dnguyen92 Interior / Audio / Electronics 9 09-30-2011 04:36 AM
speedometer/odometer not working marewrath Interior / Audio / Electronics 7 04-20-2011 10:46 PM
Speedometer and Odometer not working 31dev31 Tech Archive (No Posting) 6 04-12-2010 06:18 PM
99 honda civic si Speedometer and Odometer not working CivicSF Tech Archive (No Posting) 21 08-31-2009 12:19 AM
Speedometer and odometer problem kevin12 Tech Archive (No Posting) 6 05-13-2009 11:27 AM

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -4. The time now is 04:08 PM.


Powered by vBulletin® Version 3.8.5
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vB.Sponsors
User Alert System provided by Advanced User Tagging v3.1.3 (Lite) - vBulletin Mods & Addons Copyright © 2014 DragonByte Technologies Ltd.
Copyright 2007 ClubCivic.com
Best Prices on Aftermarket Car Performance Parts
Freelance Web Design

Store News:

Latest Topics:


Store Specials:

ALL
Unanswered Topics:





Copyright 2011 ClubCivic.com - ClubCivic.com is in no way affiliated with Honda Motor Company