PDA

View Full Version : Horrible times.


EG Hatch
04-18-2009, 02:19 AM
So tonight I ran my friends Civic and could only net a best time of 16.93 @ 80Mph. It is a 98 Civic Si, d16y8. Why is it so pathetically slow? I nailed the shifts. Launch was mint. I just don't understand how the car could be so slow. I looked up a site and it says they should run 16.7-17.2... WOW

reyscivic
04-18-2009, 02:23 AM
well first off in the US there is no civic si in 98 unless you are i Canada ,second you have a D series, they were meant to be gas savers, and third its a civic.

eskateboarding7
04-18-2009, 02:23 AM
So tonight I ran my friends Civic and could only net a best time of 16.93 @ 80Mph. It is a 98 Civic Si, d16y8. Why is it so pathetically slow? I nailed the shifts. Launch was mint. I just don't understand how the car could be so slow. I looked up a site and it says they should run 16.7-17.2... WOW

You answered your own question.

EG Hatch
04-18-2009, 02:26 AM
shitty deal. i expected a little better time than that.

reyscivic
04-18-2009, 02:28 AM
dude its a civic 130 hp at its best dude it will be very slow

EG Hatch
04-18-2009, 02:31 AM
yeah, true story. oh well, lol. still had some fun. my one run was a 16.9999, pretty cool.

Melt
04-18-2009, 02:53 AM
whats your elevation .... that hatch should be in the low 16s i was pulling that with my integra at only 158 ft above sea level

Destroy
04-18-2009, 03:16 AM
dude its a civic 130 hp at its best dude it will be very slow

Prob half that at the crank.

got traction
04-18-2009, 05:11 AM
you suck at the 1320?

EK|B
04-18-2009, 11:40 AM
Answer: It's a Civic.

JDMneeds
04-18-2009, 11:43 AM
civics are slow either swap it boost it or get over it.

EG Hatch
04-18-2009, 05:34 PM
Im over it. I just didn't think it was that bad. I don't know my exact elevation. My friends ran decent times in their cars. 14.3's in a 08.5 speed3 and 15.1 in a mazdaspeed protege.