1. ClubCivic is now on Instagram! Follow us at clubcivicdotcom. Want your photos features? Tag or DM us, use #clubcivicdotcom, or email us your photos to photos@clubcivic.com

91CRX SI/B20b MAP Cel Code Help

Discussion in '4th Generation Honda Civic (1988-1991)' started by existanzcivicb20, Nov 8, 2017.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. existanzcivicb20

    existanzcivicb20 New Member

    Joined:
    Apr 25, 2015
    Messages:
    16
    Location:
    Chicago
    Car is CRX SI I swapped it with a B20B and car runs great until I go to full throttle I get a Code 3 MAP sensor code and then the car runs like crap. I have to turn the car off and restart it so it will run good again. The engine runs strong as long as I do not go to full throttle. Only upgrades I have on the engine is ITR headers, Skunk 2 Pro series Intake manifold and Throttle body, and 2.75" exhaust.
    Things I have checked:
    Timing is good ( checked with test light)
    Swapped out the MAP with 3 other brand newsensors
    TPS is good and calibrated (have tested 3 others I had laying around)
    I have 3 ECU's that I have tried. P28 chipped, 2 x P75 virgin
    Fuel Pressure 28psi at idle with the vacuum line connected to the FPR and 38psi disconnected
     
  2. civteck

    civteck Respected

    Joined:
    Sep 6, 2017
    Messages:
    108
    Location:
    NJ
    How are you calibrating the tps? Any cel's?

    Sent from my boujea ass phone
     
  3. existanzcivicb20

    existanzcivicb20 New Member

    Joined:
    Apr 25, 2015
    Messages:
    16
    Location:
    Chicago
    Volt meter. and no other cel codes besides MAP sensor code 3
     
  4. civteck

    civteck Respected

    Joined:
    Sep 6, 2017
    Messages:
    108
    Location:
    NJ
    WOT or closed? What values are you setting it to?

    Sent from my boujea ass phone
     
  5. boofoo

    boofoo Respected Registered VIP

    Joined:
    Oct 15, 2016
    Messages:
    2,218
    Location:
    United States
    Code 3 is an electrical fault in the MAP sensor circuit.

    Start by using a multimeter to measure voltage at each of the three map sensor pins in the connector.

    Post voltage readings by wire color in the connector.
     
    Last edited: Nov 9, 2017
  6. existanzcivicb20

    existanzcivicb20 New Member

    Joined:
    Apr 25, 2015
    Messages:
    16
    Location:
    Chicago
    closed to WOT, .5v to 5v.

    Boofoo I have done this but cant remember the exact values. I will check it out after work and post the results.
     
  7. boofoo

    boofoo Respected Registered VIP

    Joined:
    Oct 15, 2016
    Messages:
    2,218
    Location:
    United States
    For the initial test, unplug the map sensor and then measure voltage at the connector pins with the key in the ON(II) position.
     


Share This Page