1. New Forum Software:
    We have finally upgraded the forum software due to it being so outdated. If you are having any issues with new forum please let us know. Please post any issues in this thread http://www.clubcivic.com/forum/threads/clubcivic-com-forum-upgrade.227221/

A/C compressor clutch not engaging

Discussion in 'Engine Tech / Drivetrain' started by floralvikings, May 16, 2010.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Hey everybody, new user :(

    Anyway, I've been working on my a/c since I bought the car. It's a '95 LX sedan, and the problem is electrical, I'm sure.

    Everything works mechanically, has a new compressor, condenser, several new pipes, and recently charged. The only problem is that nothing comes on =( I think it's either the compressor relays or possibly the ECU.

    I currently have a toggle switch rigged up to directly turn the compressor on, just to make sure everything works, and I'm having no problems with any parts, no leaks, nothing. If I could just get the thing to turn on it would be working perfectly and I could get on to something more fun :lol:

    Anyone have any advice on what it could be or how I could go about testing it?


    [EDIT]
    Oh and the light in the A/C button on the HVAC controls is coming on, if that helps at all. I'm about to have to head to work but hopefully I'll have some daylight left to work on it when I get home.
     
  2. buzzbombtom

    buzzbombtom captin sleep0 Registered VIP Registered OG 5+ Year Member 10+ Year Member

    Joined:
    Nov 11, 2003
    Messages:
    6,315
    Location:
    Nor Cal
    does the fan turn on without the a/c?
     
  3. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Yeah fan comes on fine, all controls on the HVAC controller work which leads me to believe that the switch is not the problem
     
  4. buzzbombtom

    buzzbombtom captin sleep0 Registered VIP Registered OG 5+ Year Member 10+ Year Member

    Joined:
    Nov 11, 2003
    Messages:
    6,315
    Location:
    Nor Cal
    check all the relays
     
  5. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Is there any way to test them without actually replacing them? I can probably pick up some new ones this week if not.
     
  6. JDeg6

    JDeg6 New Member

    Joined:
    May 13, 2010
    Messages:
    73
    Location:
    Tennessee
    I have the same sort of problem, when i got my hatch the wiring for the radio had been hacked so at the time i had ac/heat but no radio. So after going to Pull-A-Part n getting a new radio harness i spliced em and hooked it back up and Wa-La!!! i have a cd player now but NO ac/heat...
     
  7. JDeg6

    JDeg6 New Member

    Joined:
    May 13, 2010
    Messages:
    73
    Location:
    Tennessee
    it sucks man, i need to get mine workin to.
    dont know about you but either i cant drive in the rain or i can im just driving around town with foggy ass windows.
     
  8. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    The relays for the condenser fan and compressor clutch are interchangeable so try swapping them.

    When the compressor won't engage, you also want to check whether the ECU receives voltage from the compressor clutch relay and that the ECU also sends 5V to the heater control panel. If all of this fine, then the ECU may be bad.
     
    Last edited: May 27, 2010
  9. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Ok, I'll try swapping the relays. Where on the ECU harness is are the wires for the relay and heater control panel? My manual got flooded in the last hurricane and I haven't picked one up yet >.<


    [EDIT]
    Okay, swapped the relays. In one configuration, the condenser fan is coming on with the a/c switch, so I know it's not the HVAC controls. But, no matter which relay is where, the compressor doesn't come on. I tried jumping the compressor power to the condenser fan, and it engaged no problem, blew cold, everything a-okay.

    So, does that sound like one of the relays is bad? I figured that since the compressor isn't coming on despite which relay is being used that it's something else.
     
  10. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    The relays are fine.

    Here are the relevant ECU pins for the A/C compressor. A15 provides ground to the relay and B5 sends voltage to the dash control panel.

    [​IMG]


    If you have voltage at both wires, then jump the pressure switch. If the compressor still won't engage, then the ECU may be bad.
     
  11. buzzbombtom

    buzzbombtom captin sleep0 Registered VIP Registered OG 5+ Year Member 10+ Year Member

    Joined:
    Nov 11, 2003
    Messages:
    6,315
    Location:
    Nor Cal
    seeing as your car was flooded i am going to say its a wire issue. is this a stock a/c system? also check to see sometimes if it was installed after market even an oem one after original sale it could be rigged non-oe style, mine is spliced into my harness (previous owner) check there too if that is the case...
     
  12. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    It's the stock a/c I believe. The car itself wasn't flooded, just my basement, where the manual was at the time >.<

    Checking out the ECU and switch now...


    [EDIT]

    Well, my multimeter seems to have crapped out altogether (not surprising since it hasn't been used in several years...) So the only thing I have to use is a probe... Will that work for checking whether there is voltage?

    [EDIT]

    Got multimeter to work, both wires are getting voltage. Jumped switch, no compressor. Bad ECU?
     
  13. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    Try swapping in a known good ECU. This would be the next logical step.
     
  14. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Okay. I'll have to go pick one up today if I can find the time. Will post if I can get one.


    I'm probably gonna be able to go to a pick and pull later today, should I pick anything else up that might be worth trying to replace?
     
  15. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Whelp, got the time to get out to a couple junkyards but no didn't have the time to go to the actual pick and pull. None had an ECU that they would warranty and I really don't want to buy one just to find out it doesn't work and that I can't trade for another one.

    So, basically, I can't get one unless I have the time to hunt down and pull one out myself, but I know the pick and pull warranties anything you get for 10% extra so if it doesn't work I can go get another one. Only problem is I probably won't be able to get out there until next week.

    Anything else you guys can recommend trying that could fix the problem?
     
  16. j0keefe21

    j0keefe21 New Member 5+ Year Member

    Joined:
    Feb 11, 2009
    Messages:
    62
    Location:
    mass
    try to see it the clutch coil is working
     
  17. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    The OP's statement above indicates that the compressor clutch coil is fine.
     
  18. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    Spent all day at pick and pull looking through cars. They recently got rid of a bunch of cars (apparently, because there used to be half a dozen that were compatible with mine) and there were only 2 5th gens left with a compatible ECU (On opposite ends of the junkyard, one was hiding in the Nissan section) and both had the ECU removed already. Total downer.

    Any idea where I could pick one up cheap online?
     
  19. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    You may want to post a thread in the Parts Wanted section and to scout eBay for a deal.
     
  20. floralvikings

    floralvikings New Member

    Joined:
    May 16, 2010
    Messages:
    94
    Location:
    Seabrook, Texas
    I have to rant here a little bit. I found a guy who says he has my car, exactly, same year, make, model, trim, transmission, everything, in his lot, with ECU in, and he'll give me the ecu for $45. So I'm freaking stoked, even though it's like 45 minutes away (closer to an hour in traffic) I'm out the door. I get lost looking for the place because it's kinda sandwiched in between two other junkyards, but I eventually get there.

    And the freaking car is an automatic. ARGH. And it looks like the cheapest I can get one online is about $70, and there's no guarantee that it'll even work.

    [EDIT]

    Oh, and mine was wrecked awhile ago, so I was kinda hoping this car would have the parts I need to finally finish it off, but it's freaking missing literally every part i want.
     


Share This Page