1. ClubCivic is now on Instagram! Follow us at clubcivicdotcom. Want your photos features? Tag or DM us, use #clubcivicdotcom, or email us your photos to photos@clubcivic.com

Climate control

Discussion in '6th Generation Honda Civic (1996-2000)' started by Atlej8, Jul 17, 2015.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. Atlej8

    Atlej8 New Member

    Joined:
    Jun 27, 2015
    Messages:
    8
    Location:
    Atlanta
    I have a 98 civic coupe i was wondering y doesn't my climate control work it does blows from the front but it dosent switch at all.. lights from the control don't come on either

    Sent from my N9130 using Tapatalk
     
  2. Mr.Baker

    Mr.Baker Mr. Search Registered VIP 5+ Year Member

    Joined:
    Jul 19, 2011
    Messages:
    2,153
    Location:
    Fingerlakes Region, NY
    8th gen section?
    What does that mean, "it blows from the front"? You need to be more specific about what doesn't work.
     
  3. HeX

    HeX Authoritah, respected. Staff Member Registered VIP 5+ Year Member

    Joined:
    Jan 22, 2011
    Messages:
    3,411
    Location:
    Space Coast, Florida
    Yes. More details please. Some punctuations wouldnt hurt either. Does it not switch which vents are open to blow air? If so, then its the vent control regulator (under the drivers side of the dash). If it does not switch from hot to cold, then its the cable on the slide control. Also, specify which dash lights arent working. Is it the button indicator lights (above the button) or the button displays?
     
  4. bairdandrew77

    bairdandrew77 New Member

    Joined:
    May 11, 2015
    Messages:
    80
    Location:
    Utah
    Broken wires? Internals worn? Unit came unplugged? There's too many possibilities and no information

    Sent from my SGH-T399 using Tapatalk
     


Loading...

Share This Page