1. ClubCivic is now on Instagram! Follow us at clubcivicdotcom. Want your photos features? Tag or DM us, use #clubcivicdotcom, or email us your photos to photos@clubcivic.com

Loud pop after jumpstart

Discussion in '8th Generation Honda Civic (2006-2011)' started by BrandonC92, Jul 24, 2016.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. BrandonC92

    BrandonC92 Respected

    Joined:
    Feb 10, 2016
    Messages:
    13
    Location:
    Salem
    This morning I went to start my car and it didn't start so I got a jumpstart. after A few minutes of idle the car made a loud popping sound and smoke came from under both sides of the hood. Engine also seemed to be louder then normal for a short period nothing seems to be leaking no hoses look broken ac is still blowing cold air. Does anyone know what this might be from?
     
  2. BrandonC92

    BrandonC92 Respected

    Joined:
    Feb 10, 2016
    Messages:
    13
    Location:
    Salem
    Well alternator died
     
  3. buzzbombtom

    buzzbombtom captin sleep0 Registered VIP Registered OG 5+ Year Member 10+ Year Member

    Joined:
    Nov 11, 2003
    Messages:
    6,498
    Location:
    Nor Cal
    I bet its your alternator
     
  4. Donna60

    Donna60 New Member

    Joined:
    Nov 16, 2017
    Messages:
    1
    Location:
    Crestview,FL
    Brandon, was it the alternator?
     


Loading...

Share This Page