Amps giving me trouble.

Jimmy2times

White, middle-class
Registered VIP
5+ Year Member
#1
sooo, for some reason, as of a couple weeks ago, my amplifiers (a alpine 400watt mono and 75 watt 4ch) have been staying on after i turn off the car. i know they shouldn't be staying on but for whatever reason, they are.

it's already killed on battery and i wanna fix this asap, seeing as the car's my daily.
 

kaace

I'm getting there...
Registered VIP
5+ Year Member
#2
if they are connected to the deck via the remote turn on wire then you have a problem with the deck...change the remote turn on wire to something you know turns on and off with the car...the deck might have two outs, one for the remote turn on and one for a power antennae...changed it from one to the other if thats the case...

do you visibly see the amps still on? are you sure they are not just powering down...some LEDs stay on for a few minutes and slowly fade after the amps have been turned off...

let me know what you find out....
 


knightxrider1

New Member
Registered VIP
5+ Year Member
10+ Year Member
#4
i spliced into the remote wire so i can switch it off and on whenever i want. i dont need bass at 6:30 in the AM when im going to work. plus my girl cant handle the boom boom sometimes.
 


kaace

I'm getting there...
Registered VIP
5+ Year Member
#5
i spliced into the remote wire so i can switch it off and on whenever i want. i dont need bass at 6:30 in the AM when im going to work. plus my girl cant handle the boom boom sometimes.
there is NOTHING better than Digweed on the way to work in the mornings...bumping that s**t in traffic when everyone else is half asleep...its better than coffee....
 

Jimmy2times

White, middle-class
Registered VIP
5+ Year Member
#6
ok so:

they did stay on all the time. idk what the problem was, but i solved it simply by running my amps' power supply through a fuse that would turn on when the key was turned to accessory.

bought a new battery and threw that in too.





btw. w3rd on poundin through the streets in the morning but i have a feeling that my music scares the s**t outta people. (listen to a band called emmure and u'll have an idea of what i use the bass for. lol.)
 

postal21

vroom vroom
Registered VIP
5+ Year Member
10+ Year Member
#7
btw, dont run an amp off an antenna lead. otherwise your amp/subs will turn off when you switch your source to cd/aux/ipod etc. :P

but yeah, accessory power will work pretty much like a remote wire on most radios for powering the subwoofers.
 




VigLink badge