brand new clutch but tranny is slipping?!

#1
Sup cc i just swapped a different b16 tranny onto my em1 with new exedy oe clutch kit but didnt replace the flywheel my mechanic said it looked pretty worn out but i kept it . Now my car feels like the clutch is slipping! I press the gas & the car doesn't react to it and all of a sudden it catches gear? Am i looking at a bad flywheel or sensor? Or maybe wrong clutch installation? Also previous owner adjusted the clutch pedal for faster shifting. Can that cause it to slip?
 

Shaaaft

FNG
Registered VIP
5+ Year Member
#2
How did he adjust the clutch? It could be that or it could be the flywheel, it's hard to tell.
 


Shaaaft

FNG
Registered VIP
5+ Year Member
#4
Depends. Did it slip before you put the tranny in? If no, then it's unlikely it's the clutch pedal itself.

I would bet it's the flywheel.
 


00siboy

lurkin...
Registered VIP
#5
Did you get the flywheel resurfaced? The flywheel surface can become worn and get heat spots, so most of the time people will resurface it to level out the surface and get rid of the heat spots.
 

JohnS.

BANGARANG
Registered VIP
Registered OG
5+ Year Member
10+ Year Member
#6
You should never re-use a used flywheel until you get it resurfaced... You're wearing out your new clutch faster. Take it off asap and either buy a new flywheel (I recommended lightened) or get the one you have resurfaced before you put anything back together.
 
#7
@shaaft- no the tranny never slipped i just bought an exedy fidanza lighten flywheel. hopefully this is where the problem is at

@00siboy- no i didnt i reused old flywheel :/

@johns- thanks for the advice =)
 




VigLink badge