can someone plz help

#1
Ok i need help with my timing. I have a 93 cx but a d15b7 engine. i cannot get the ignition timing right. What am i doing wrong. I let car warm up all the way and i then shut car off and jump the service plug. turn it back on and when i take timing light to it the best i can get timing is 14-15 degrees btdc should be 16 and the dizzy is maxed out towards the front so its retarded. i must have the cam off. I know the lines are suppose to line up with the head. Does any one have a close up of their car i can see how its suppose to be?
 

95CTR

52mpg? I do it all day.
Registered VIP
5+ Year Member
#2
did you get your issue solved yet, if not i have the stock CX D15B8 in my car still, i can go take what ever pictures your needing and email them to you... just let me know.
 


95CTR

52mpg? I do it all day.
Registered VIP
5+ Year Member
#4
okay let me go out there with a socket and junk and ill turn it over to TDC for ya, in the mean time give me your email so i can send it to you.
 


95CTR

52mpg? I do it all day.
Registered VIP
5+ Year Member
#6
no big man, it happens...now just remember, the pic that im sending you is no AT top dead center but it shows the marks needed to get it there... it will be a visual reference only seeing as you have the B7 in there now and i have the B8, its prolly the same, im just warning you ahead of time.

if you still can figure it out let me know and i will actually put mine at top dead center and take a new picture for you.

email is sent btw
 




VigLink badge