car dropping temp randomly

Discussion in 'Engine Tech / Drivetrain' started by 2000sliverEX, Nov 6, 2011.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. 2000sliverEX

    2000sliverEX New Member

    Joined:
    Jun 21, 2011
    Messages:
    146
    Location:
    valley center california
    went for a run up palomar mountain today. car ran fine all the way up and at normal temp and i was running at high rpms the whole time. we stopped at the top and let are cars chill for a little while then headed back down. i cruised the whole way down and the temp was still running at about 210. but once i got to the bottom its just dropped to were the gauge was reading zero. i pulled over to check it out and there was a little smoke and it smelt weird too. i let my car sit for about ten minutes and the temp started to climb again so i decided to head home and it just chilled around 210 again and the smell went away. im drawing blanks on this and so are my friends are too, can anyone help me out with this?
     
  2. Cobl18

    Cobl18 New Member Registered VIP

    Joined:
    Jan 24, 2011
    Messages:
    335
    Location:
    Austin, Texas
    maybe your cars thermostat is stuck open?
     
  3. ImportFan1

    ImportFan1 Super Moderator Staff Member Registered VIP Registered OG 5+ Year Member 10+ Year Member

    Joined:
    Nov 16, 2003
    Messages:
    11,194
    Location:
    Cincinnati, OH
    Yeah. Bad thermostat. Have the same issue with my R32 right now. Just needs to be replaced.
     
  4. 2000sliverEX

    2000sliverEX New Member

    Joined:
    Jun 21, 2011
    Messages:
    146
    Location:
    valley center california
    thats what i had thought and was hoping that cuz its and easy fix haha. would that be the reason to the smell too?
     


Loading...

Share This Page