Dome light not working.... tried everything

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#1
hey guys. ive done a bunch of research on how ti fix my dome light. it has never worked since i got the car.

i have checked the door hook ups, the ground on the switch, my radio has the two wires spliced since its an after market head, the fuse is good..... the bulb is brand new. i dont know what else to check to make this light turn on. it does not work in any position. i also pulled the switch out and examined it.... looks fine and perfect. like its making all connections....



any ideas on whats wrong? thanks
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#2
it also occured to me the the headlight busser does not work either and i have heard that these two things are linked to each other. is there a fuse for headlight buzzer?
 


4bangincivic

sup
Registered VIP
5+ Year Member
#3
it also occured to me the the headlight busser does not work either and i have heard that these two things are linked to each other. is there a fuse for headlight buzzer?

Have you checked power going to the buzzer?
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#4
wheres the buzzer? i know on the teg its on the back of the fuse box
 


gotcher17

New Member
5+ Year Member
#6
my dome light doesnt work either and neither does my keyless entery remote... mine doesnt work because the factory head unit was removed and they wont work without it
 
#7
What year Civic???

Are you sure you checked 7.5A hood fuse 43?

Does the Wht/Red wire at the dome light have voltage to body ground?
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#8
its frankenstien. the shell and dome light is a 98 hb dx. the floor harness, dash all electricals are from a 96 ex.

everything is connected. no unwanted grounds or nothing. fuse is good too.

it could be the switch but i think its something that is the light is connected to like my headlight buzzer cause that doesnt work either

the busser goes off if i pull out a fuse and put it back in but i cant remember wish one. i think its fuse 15 though
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#9
my dome light doesnt work either and neither does my keyless entery remote... mine doesnt work because the factory head unit was removed and they wont work without it
yours is an easy fix. splice l grn/red wire to grn/black wire and done
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#11
i am 95% positive the switch is getting voltage or i would like to think that.

now ive looked all around the car tested the door switches and everything is hooked up an works.

now i did find a plug with two wires white red and green black. this plug is just sitting there, not plugged into anything. i am thinking that is it, but here is where im lost. the fuse for the dome light is under the hood. so why would another plug for it be behind the the fuse box under the dash???<- thats if this plug is even for the dome. also the two wires coming out of the dome liught aree green red and white red. so it doesnt match the plug. the door wires are green red on the passenger and driver is solid green.
im really lost on it. dooes anyone know where the dome light harness goes? im sure it leads somewhere by the passenger side. down the frame towards the hood fuse box.

is it possible to just find the dome harness and splice it into a power supply since it has its own switch?
i would rather do it correct but i need mroe direction on this.


i also placed a fuse in every terminal that was missing one in the fuse box and still nothing....
but i did get the defroster and headlight warning working. one of the fuses placed in the terminals turned them on.
 

JDM_SPEC_SI-R

New Member
Registered VIP
5+ Year Member
#12
got it!!!


si guys the damn connection harness from the 98 dome light is different from the 96 harness.

i actually ended up findgingt he 98 harness and splicing it into the icu and a harness from the back of the fuse box.

the plug was never even connected from the dome light thats why it was not coming on. but its fixed and working now.... damn dome light.

now onto the rear wiper switch setup with a non rear wiper main harness under the dash!
 
#13
got it!!!


si guys the damn connection harness from the 98 dome light is different from the 96 harness.

i actually ended up findgingt he 98 harness and splicing it into the icu and a harness from the back of the fuse box.

the plug was never even connected from the dome light thats why it was not coming on. but its fixed and working now.... damn dome light.

now onto the rear wiper switch setup with a non rear wiper main harness under the dash!
Hey guys i need some help regarding the dome light issue.

So i have checked all the fuses under the hood and in dash all are good. Then i tried checking the dome light assembly. The part which got confused was that when i took the dome light plug out it had only two wires and the plug has 3 points which means one is missing for some reason. And then i looked at the sunroof plug and one was missing from them too.

I think the doors are fine because when i open the doors the rear map light goes on.

The switches at the from map light are bad. So i tried taking out the switches from the rear side lights and the map light did work but only when it was turned at door but that too only when i switch it on and when i get the switch in off and then push the light it does not go ON.

So one thing is am sure about is the switches are bad but i dont get the part where it doesnt turn ON when i push it.

Will appreciate any help regarding this issue.
 




VigLink badge