help!! B18b1 into 95 civic coupe



D16z6_Tuner

n i g h t c r a w l e r
5+ Year Member
10+ Year Member
#1
i swapped a b18b1 from a 94 gs into my 95 civic coupe. ok here's the problem. the throttle cable is too short. when i bolt up the bracket to the manifold and put the cable on it, it won't reach the the throttle body. am i supposed to take the cable off of the integra or is there any other way that i can do it. need help bad.
 


weksos

New Member
Registered VIP
5+ Year Member
#2
you'll need the throttle cable from the Integra.
 

D16z6_Tuner

n i g h t c r a w l e r
5+ Year Member
10+ Year Member
#3
would you happen to know about how i would go about takin it off, cuz i took a look at it and just took a deep breathe and just left it alone.
 


99siTUNER

New Member
Registered VIP
5+ Year Member
10+ Year Member
#4
I duno why the stock cable wouldnt work, I used a stock on on my gsr engine in a 94 hatch....and its too long at that....what are you trying to take off? the stock cable or the one on the integra?
 

99siTUNER

New Member
Registered VIP
5+ Year Member
10+ Year Member
#6
I personally never took one off, obviously you know there the little metal bolt like thing that fits the groove on the actual throttle body, inside the car there SHOULD be a way to release the whole cable from the pedal, We took off a cruise control cable the other day and getting to it was the hardest part (remove some of the dash pieces and get way up in there) but it came off simple enough, im sorry thats the best I can do!!

does the stock cable just not reach far enough or what? got a pic of the length? mine is so long it bows up from the firewall to the throttle body, hits the hood when I close it! so Im not sure whats going on with yours
 

bmoua

New Member
Registered VIP
5+ Year Member
#7
my roomate had the same problem bro....you can get the throttle cable off any teg and 99-00 si...
 

D16z6_Tuner

n i g h t c r a w l e r
5+ Year Member
10+ Year Member
#8
i went ahead and took off the throttle cable from the teggy and put it on my car. works just fine. thnx for the help guys, really appreciate it.
 




VigLink badge