Hesitaion Issue Please Help!!



#1
Hey guys new to the site!! I recently bought a 99 civic lx 5spd 193k miles and all stock. When the car is cold and I take off down the road it's spits and sputters and misses like it's running outta gas. The car starts up and idles just fine when cold just acts up when I take off down the road. When up to normal operating temp it does not do this, Any ideas what this might be so i'm not chasing my tail? Thanks in advance!!
 

Trekk

New Member
Registered VIP
#3
The car would be in open loop when it was cold so the o2's shouldnt matter. Check your plugs maybe first, when a car is truly cold it will run rich till it warms up to operating temp, then goes closed loop and works off feedback.
 
#5
Yeah the cel is on. I havnt went to autozone yet to get the codes read. The guy I got it from said they told him it was something to do with the exhaust so with that in mind I just assumed it was an 02 sensor like every other civic ive owned. However this particular issue just didn't seem to fit the bill for for being related to an 02 sensor so I figured i'd check with you guys and see what you had to say about it. Thanks!
 
#6
Noone out there has ever experienced or heard iof this issue? I really hate to have to take it somewere if it's something relatively easy to take care of. Thanks!
 

Cobl18

New Member
Registered VIP
#7
It might be irreverent but my girlfriends accord did this for like the last week, it's just now getting cold in Texas. I cleaned the map sensor and mass airflow sensor. I cleaned the upper throttle body 2 weeks ago really good because her egr valve was clogged. After spraying B12 chemical (essentially seafoam) into it and scrubbing it really well and making sure all the sensors in the intake were clean it runs perfect now. You might should try this. Made her gas mileage go from 20 mpg to 28 mpg. I probably pulled out a whole pound of sludge and soot. 205,000 miles and still kickin =)
 

emerican

New Member
Registered VIP
#10
If its throwing a cel which you can obvisly see and there reader says nothing is wrong i say autozone fucked up wouldnt be the first time they aint exactly known for car smarts at least around me.
 

Cobl18

New Member
Registered VIP
#11
Yeah they told me I didn't need a harmonic balancer tool and to just stick a breaker bar on the bolt and bump the engine. I litterally had to pull up a YouTube video that showed the engine spun counter clockwise. The best thing to do is just buy your own code reader for like 50 bucks on eBay. Mines pretty nice! You can try and seafoam your engine.
 




VigLink badge