idle problem!



dasltc

New Member
5+ Year Member
#1
--------------------------------------------------------------------------------

my EG8 D15b vtec got idle problem quite a long time already,now think wanna solve the problem,last time ever try to change the IAC but still the same,got people suggest me try to change the TPS sensor,but need some advice from the forumer here.
if i buy the recon TPS sensor from chop shop,did i need to buy the TPS sensor wire togather or i just need to buy the only small TPS sensor at throttle body there??
 


b16bang

New Member
Registered VIP
5+ Year Member
#2
ummm..the tps for the 5th gen is riveted to the throttle body. This i kno for a fact because i too have idle problems and have replaced the TB, IM, and IACV.....yes i kno....so...if u buy a new tps u'd have to buy a whole throttle body.
 

12.8:1 Ls/vtec

IT'S OVER NINE THOUSAND!!
Registered VIP
Registered OG
5+ Year Member
#3
b16bang said:
ummm..the tps for the 5th gen is riveted to the throttle body. This i kno for a fact because i too have idle problems and have replaced the TB, IM, and IACV.....yes i kno....so...if u buy a new tps u'd have to buy a whole throttle body.
No you don't. You can just get a dremmel and make a slot across it and take it off with a flat head screwdriver. Did you ever think of having to put one on an aftermarket throttle body that doesn't come with one.
 


T!mmy

New Member
Registered VIP
5+ Year Member
10+ Year Member
#5
b16bang said:
i'm guessing you would have to rivet the aftermarket one to it as well....
no...it's threaded. so you can just reuse the ones you slotted if you'd like...
 

b16bang

New Member
Registered VIP
5+ Year Member
#6
wtf???/ get me pics of this.....because that coulda prolly save me about $200 right there

*goes to look for TB receipt*
 

Svr_Civic

dont try, dont fail
Registered VIP
5+ Year Member
10+ Year Member
#7
the tb screw is jsut that... a rivetless screw. Take a dremmel tool to make a slot, hell i used a hack saw to make just a line in there so i can fit my phillip screwdriver on to the head of it. Remember lefty loosey and ur on ur way. Any scew will go back in if its the right size of course, doesnt have to be a rivet. And if you spent 200 bucks on a tb ? lol
 

Svr_Civic

dont try, dont fail
Registered VIP
5+ Year Member
10+ Year Member
#11
i would first check the volts on the tps. .5 is idle i believe and when u raise the idle the volts increase. Something like that check ur haynes manaul to be sure. Another trick to see whats goin is, the one i did, is to start the car. If the idles all up and down unplug the tps. Let it idle a little bit more and if it stops, and seems to idle fine..but the tps back in teh slot and be on ur way knowing you know what the problem is. Of course when you turn off your car..the idle will be horrible once again unless you unplug it then put it back in.
 

guwakjai010

Dr Tai tai
Registered VIP
5+ Year Member
10+ Year Member
#12
wat exactly is the idle problem? bouncing rpm while start up? or low idle...
 

dasltc

New Member
5+ Year Member
#13
my case is like this,when the compressor kick in,the rpm seems drop from 650(normal) to maybe 400 then back to normal again,and my engine seems vibrate a while then to normal!wat happen actually??
 

henkz0r

Unobtanium Member
Registered VIP
5+ Year Member
10+ Year Member
#14
dasltc said:
my case is like this,when the compressor kick in,the rpm seems drop from 650(normal) to maybe 400 then back to normal again,and my engine seems vibrate a while then to normal!wat happen actually??
Sounds normal to me. When your compressor clutch engages, there's more load on your engine. So there's going to be a drop in rpms. The IACV says whoa, rpms are too low, let's increase air/fuel to get the idle where it should be. Completely normal.

You'll exhibit the same effects if you have power steering and you turn your steering wheel at idle. Also if you have power windows or a sunroof, there's more draw from the alternator, which means more load on the engine. Engines with low torque will have this problem.
 

dasltc

New Member
5+ Year Member
#15
i have juz found tat my idling is unstable when open the aircon,wat thing should be i change?whole throttle body??
 




VigLink badge