Indiglo guages mess up guages?



Gonzo

Tin Foil Member
Registered VIP
5+ Year Member
10+ Year Member
#1
I was readin somethin and the guy said he replaced his cluster cuz his indiglo's made his tach jump and his temp not work. I have those same problems but i thought that they were just jacked up. Ne one else have this problem?
 


c_diddy

drove through a tree
Registered VIP
5+ Year Member
10+ Year Member
#2
Gonzo said:
I was readin somethin and the guy said he replaced his cluster cuz his indiglo's made his tach jump and his temp not work. I have those same problems but i thought that they were just jacked up. Ne one else have this problem?
how did you put them on? or were your gauges already messed up? I don't see how the indiglos would screw up the cluster by itself. The guy you're talking about was most likely at fault when he installed them...most people try picking out the needles when you're supposed to just slide them in. pulling out the needles will damage the gauges....or if you decided to cut some wires and hit the wrong ones :what: ....
 

Gonzo

Tin Foil Member
Registered VIP
5+ Year Member
10+ Year Member
#3
when i put them on i just slid them on and i never had cut ne wires and my guages were fine before i put them on then they progessivly messed up
 


j_fukin_t

New Member
Registered VIP
Registered OG
5+ Year Member
10+ Year Member
#4
yea they mess em up alright = the are gay ;) leave indiglo's to ford and chrysler ;)
 

stolibears

Use your dipstick Jimmy!!
Registered VIP
5+ Year Member
10+ Year Member
#5
i've never had issues with mine. I didn't have to do anything to my gauges, they just slid on very carefully and made extra care of the needles.

the only thing I've heard is the little power supply going bad on them, but I've had mine for about 4 years now and no troubles.
 




VigLink badge