No Power to fuel pump

Status
Not open for further replies.

Sparxs301

New Member
i have a 94 civic hatch with an h22 swap so i stoped at a store and got back int the car and car didnt start so i did research i replaced fuel pump and main relay both are working and the only time the pump comes on is when i connected to my battery did voltage test and no power checked grounds like thermostat housing and ground on pump they are good checked fuses and they are good traced wires and didnt find any that were messed up i tested for spark and im getting spark from the dizzy and im at a standstill and pissed lol was wonderin if any one can help or if i can find another sort of power to connect it to please call me or reply my number is 301 343 8087
 

RonJ

Banned
1) Unplug the main relay and then turn the key from off to ON(II).

2) Use a jumper wire or paperclip to jump terminal 1 to terminal 7 in the main relay plug. Does the fuel pump run?

3) Now use the jumper wire or paperclip to jump terminal 5 to terminal 7 in the main relay plug. Does the fuel pump run?


 


Sparxs301

New Member
wats the difference from doin this and difference by runnin wire to fuel pump and it kicked on when i ran wire from battery
 

RonJ

Banned
wats the difference from doin this and difference by runnin wire to fuel pump and it kicked on when i ran wire from battery
It tells you whether the main relay gets voltage from fuses 31 and 24. Not getting voltage from those two fuses could cause the problem you are having.
 


Sparxs301

New Member
ok so i will try and test that ty wat else could i do after that

ok i tryed jumpin 1-7 with paper clip and got nothin then jumped 5-7 and nothin but sense my car has been sittin the battery is weak does that matter and i heard the relay click twice with and with out jumper
 
Last edited by a moderator:

RonJ

Banned
Use your multimeter first to measure voltage across the two battery posts. Set the meter to read DC volts on the 20V scale, if your meter does not auto scale. If you are not familiar with your meter, post a picture and I'll guide you through some simple tests.
 

Sparxs301

New Member
ok when i tested 1-7 and 5-7 should they have kicked the pump on when i jumped them and where is fuse 31 at underhood
 

Eg8builtz6

New Member
I have had a similar problem but with a good battery, I simply unplugged the computer while the ignition swished on plugged it back in and it worked fine.
 

Sparxs301

New Member
well i found a soltution i ran a wire to the main relay fuse (15)amp then ran a 20 amp fuse holder and ran wire to the pump so it works great
 

DSargent09

New Member
Made this account because I am having a similar problem. I jumped the terminals how you directed, and I get power to the pump. If I jump 7 to 8 the car will run so clearly the fuel pump is not getting power.. Replace relay or do you have another direction or part I should check first?

1992 Honda civic. rz 0132 is the main relay...
 

RonJ

Banned
Made this account because I am having a similar problem. I jumped the terminals how you directed, and I get power to the pump. If I jump 7 to 8 the car will run so clearly the fuel pump is not getting power.. Replace relay or do you have another direction or part I should check first?

1992 Honda civic. rz 0132 is the main relay...
I replaced the relay, and still have the same problem. No power to the fuel pump.
  1. Unplug ECU connector A.
  2. Turn key to ON(II).
  3. Ground the A7 or A8 terminal (Grn/Yel wire) individually to the metal frame under the dash.
  4. Does the fuel pump run?

Also:

Is there bright white spark at all 4 spark plugs, even though the fuel pump does not prime?

Any CEL codes?
 

DSargent09

New Member
Nothing. grounding both of those turned on the injectors.

Also again I was jumping 7 to 8 in the main relay and the car will start and run.

So I dont think its spark. For some reason the Fuel pump is not getting power..... I have continuity between 7 on the relay and a7 and a8 on the ECM..

With the key turned over and all terminals get 12 volts except for 6 and 7, and obviously the ground.

6 gets power when I turn the key over as it should.

Will it cause a problem if I jump 5 to 7 or 1 to 7 and leave it jumped to drive it?

It runs fine when jumped.
 
Last edited by a moderator:
Status
Not open for further replies.



Top