Steering wheel



marneli10

New Member
Registered VIP
#1
I recently put an after market steering wheel with quick release I was jus wondering how come.the signal light doesnt turn off like it did with the stock one
 

leothelion

d:p
Registered VIP
#2
take off the hub. see the white plastic thing that spins and has 2 slots in it?? thats the tun signal deactivator. on your oem steering wheel you had two slots on the base of the steering wheel that fit onto the shaft, these lined up onto the white plastic thing and when you turned the whee, it also turned the white plastic, thus shutting off your turn signal. the only way you can get it back with an aftermaket hub is by fabricating a piece that will connect your hub to the white plastic.
 

lethal6

Das Auto!
Staff member
Registered VIP
Registered OG
5+ Year Member
#3
the only way you can get it back with an aftermaket hub is by fabricating a piece that will connect your hub to the white plastic.
Hmmm....

Mine is aftermarket and no fabrication was needed. In fact, every aftermarket hub I have ever had has included the correct provisions for signal cancellation.

Op check to see if the hub was mounted in the correct position and if it is seated correctly.
 

leothelion

d:p
Registered VIP
#4
Hmmm....

Mine is aftermarket and no fabrication was needed. In fact, every aftermarket hub I have ever had has included the correct provisions for signal cancellation.

Op check to see if the hub was mounted in the correct position and if it is seated correctly.
really? weird.. maybe i got a bad one as well. anyways here is the slots i was talking about, the back of your hub should look similar to the back of the oem steering wheel:
 




VigLink badge