Took a hard turn now bumper is messed up..with Pics



xposigroovex

New Member
5+ Year Member
#1
I know there is another bumper thread and I read it but I don't think we have the same problem. The other night I had to swerve to not hit a deer, ended up doing a complete 180 and sliding back 100 feet or more while doing 80...car seems to be fine except the bumper really. Here are a couple pics. Only one side seems to be affected. I crawled under it but have no idea what to look for or where. One pic is of the side of the bumper that looks fine, the other 2 are from the messed up side. I'd love to be able to fix it tomorrow and put on my splash guards too..any help is appreciated.



 


thexperiment

New Member
5+ Year Member
#3
man your having so many problems with your car, just like me. hopefully yours wont end up like mine.
 


xposigroovex

New Member
5+ Year Member
#5
I didn't hit anything. It was just the force of the turn. I was going 80 at least and slammed on brakes, my car does a complete 180 and slides.
 

xposigroovex

New Member
5+ Year Member
#6
thexperiment said:
man your having so many problems with your car, just like me. hopefully yours wont end up like mine.
What happened to yours? Last update I saw you had just ordered some wheels.
 

xposigroovex

New Member
5+ Year Member
#7
I popped the clips out and put them back, they were fine to start with it seems. Way too hot right now to mess with anything else but I'm going to check it out in a few hours...hopefully I'll get this done!
 

whtcivic93

www.mm-graphics.net
Registered VIP
5+ Year Member
10+ Year Member
#9
that tabs for the clips probably bent down.... check them before you pay somone for somthin easy
 

xposigroovex

New Member
5+ Year Member
#10
Honestly I don't know what else to check. I went to the library to check out a Chilton's and they have no info on bumpers in them! Here is what I have checked so far...the 5 clips that you see when you pop the trunk and the 1 screw on each of the wheel wells, like the ones in the front. I've been told there is another screw in each wheel well and 2 bolts on the under side of the bumper and you mention some "clips"...but I was under it yesterday and didn't see any of that stuff. I'll have access to a couple ramps this weekend though so I'm going to try again.
 




VigLink badge