1. ClubCivic is now on Instagram! Follow us at clubcivicdotcom. Want your photos features? Tag or DM us, use #clubcivicdotcom, or email us your photos to photos@clubcivic.com

95 civic d15 swap electrical issue

Discussion in '5th Generation Honda Civic (1992-1995)' started by Moesef, Oct 14, 2017.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. Moesef

    Moesef New Member

    Joined:
    Oct 14, 2017
    Messages:
    1
    Location:
    Minnesota
    Hey guys seein if anyone’s come across this problem before.

    Car was running good, drove it home after work, did kinda heavy rain, let it sit for about an hour and then I go to start it and nothing.
    95 honda d15 swap, no crank, can hear car door beeps, radio sometimes works, cig light plug in works, but when I turn the key to ON or switch headlights on, everything dies.

    Try a 2nd time and quiet door beeps, no radio and cig light plug in flickers.
    Got new grounds + cleaned connections on all of them including g101, and had battery tested(good) + switched with new one just to see.
    Battery clamps are good + newer.
    Main relay replaced.
    Checked all fuses replaced 80w battery fuse just in case, n replaced a 50w ignition fuse that blew.
    Also, fuel pump only worked for 1 key turn each time after I replaced the main relay and the grounds, still no crank both times.

    Was thinking a I have a short somewhere but I’m not sure where to start. Lemme know I’m at a dead end right now.
     
  2. boofoo

    boofoo Respected Registered VIP

    Joined:
    Oct 15, 2016
    Messages:
    2,223
    Location:
    United States
    Clean and tighten both ends the G1 battery and G3 transmission grounds.

    What voltage do you read across the battery posts?
     


Loading...

Share This Page