1. New Forum Software:
    We have finally upgraded the forum software due to it being so outdated. If you are having any issues with new forum please let us know. Please post any issues in this thread http://www.clubcivic.com/forum/threads/clubcivic-com-forum-upgrade.227221/

Engine hesitation: Bad O2 sensor?

Discussion in 'Tech Archive (No Posting)' started by CIVIC_VTEC, Jun 1, 2010.



Welcome to ClubCivic a Honda Civic Forum

Club Civic is an online Honda Civic forum and community for all Honda Civic enthusiasts. Whether you own a Honda Civic Si, Ex, Type R, Dx, Lx, Cx, Dx, Vx, or even a hybrid you will find valuable information and honda civic car parts on this site. Take a look around to view Honda Civic discussion; including a photo gallery, maintenance information, tech tips, as well as ways to get better performance from your Honda Civic. Visit the Members Ride's to view and rate other member’s Honda Civics. Click here to start viewing the Honda Civic Forums. Before you start posting on this site you will need to register. If you are already registered and not logged in, please login here.

Browse the forums by generation by clicking below or browse all honda civic forums.


  1. CIVIC_VTEC

    CIVIC_VTEC LOW AND SLOW! Registered VIP 5+ Year Member

    Joined:
    Feb 8, 2010
    Messages:
    349
    Location:
    Indiana
    ok when im driving around town or anywere for that fact, i feel my car hessatating sometimes, like jerking, not as fast etc. but im guessing its the o2 sensor, that messurse the amout of air and so on. and i do notice the cars ok in gas and should be faster, but de to the o2 sensor not that much. am i right?
     
  2. CIVIC_VTEC

    CIVIC_VTEC LOW AND SLOW! Registered VIP 5+ Year Member

    Joined:
    Feb 8, 2010
    Messages:
    349
    Location:
    Indiana
    and sorry for the spelling its not the best.
     
  3. DROK604

    DROK604 New Member

    Joined:
    May 14, 2010
    Messages:
    36
    Location:
    canada
    I would also check that the iacv is clean. I'm planning on cleaning mine this week
     
  4. The_Rookie

    The_Rookie New Member 5+ Year Member

    Joined:
    Sep 8, 2009
    Messages:
    210
    Location:
    ILLINOIS
    CAT converter
     
  5. nicoyita1

    nicoyita1 I eat rice. And beans. Registered VIP 5+ Year Member

    Joined:
    Apr 7, 2008
    Messages:
    1,134
    Location:
    East Coast
    Is your CEL on? If so, pull codes.
     
  6. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    :thumbs up

    Also check the spark plugs, wires, cap and rotor, as well as the ignition timing.

    If you believe the primary O2 sensor is at fault, then unplug it to see whether the problem goes away.
     
  7. CIVIC_VTEC

    CIVIC_VTEC LOW AND SLOW! Registered VIP 5+ Year Member

    Joined:
    Feb 8, 2010
    Messages:
    349
    Location:
    Indiana
    car hesitating when taking off

    ok,recently i have noticed my car when i take off it shakes a bit, but you can notice it, and allso i have noticed the hp loss and mgp loss. but i am pretty sure that it could be the o2 sensor. Front (upstream) oxygen sensor. im pretty sure thats what it is.

    which would be the second o2 sensor you see in the picture



    [​IMG]
     
  8. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    Only one thread per topic please. Two threads merged.

    Rear = secondary O2 sensor.
     
  9. CIVIC_VTEC

    CIVIC_VTEC LOW AND SLOW! Registered VIP 5+ Year Member

    Joined:
    Feb 8, 2010
    Messages:
    349
    Location:
    Indiana
    yess im sorry, i didn see my original one on here
     
  10. RonJ

    RonJ Banned

    Joined:
    Oct 20, 2007
    Messages:
    13,101
    Location:
    Houston, TX
    No problem.
     


Share This Page