light around park symbol takes forever to light up



Avant Uprising

GONE FISHIN
Registered VIP
#1
kinda weird its my beater its a 91 civic lx automatic. it seems like the colder it gets the longer it takes for the park symbol to light up on the cluster. and i cannot remove my keys but i can shut it off and start it back up. i also cant take it back out of park until it lights saying its in park. any ideas????
 

cgpEJ6

noob
Registered VIP
Registered OG
5+ Year Member
10+ Year Member
#2
I'm not that familiar with the older models but it sounds like there is an issue with the shift lock release (assuming it has that). I would guess it's just dirty around your shifter and the connection that tells your car it's in park isn't being made very well. I'd take the console out and see if you can clean up any hidden filth.
 

Avant Uprising

GONE FISHIN
Registered VIP
#3
ya thats what i was thinkin its gettin worse really sucked today but hell its also 30 degrees outside and snowing so f-it for now
 
#4
kinda weird its my beater its a 91 civic lx automatic. it seems like the colder it gets the longer it takes for the park symbol to light up on the cluster. and i cannot remove my keys but i can shut it off and start it back up. i also cant take it back out of park until it lights saying its in park. any ideas????
Check the underside of the shift lever housing. Make sure that the switches aren't dirty and/or missing.

I'm not familiar with automatics at all. That's all I can think of, some sort of switch.
 




VigLink badge